OkayFreedom cannot establish a VPN connection anymore (version smaller than 1.8.0)

If you are using an older version of OkayFreedom (1.7.5 and older) please update to the latest version. If the update is not offered to you automatically, please download and install it here: http://file.steganos.com/software/download/okayfreedom.exe

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk