Firefox 38 + Password Manager Add-on

The compatibility issue of the Password Manager extension in Firefox 38 was resolved with the following versions:


Password Manager 16.0.5:

Privacy Suite 16.1.1:


Password Manager 15.2.5:

Privacy Suite 15.2.6:

Have more questions? Submit a request


  • 0
    Web Accounts

    I like your products, yet this issue could have been solved by now.

    I wrote support when the very first FF 38 beta came out weeks ago about the issue. All I got was a wishy washy response telling me to try this and that instead of actually reading my support issue. Now here we are many many weeks later and you mention there's a problem.

    Next time try to be a little more proactive please,

  • 0

    I would really love to see a mac (OS X) version! 

Please sign in to leave a comment.
Powered by Zendesk